
Vorübung Federpendel
Diese Übung verfolgt das Ziel, Sie mit der Datenanalyse vertraut zu machen, die Sie im Physikalischen
Grundpraktikum regelmäßig anwenden werden. Der theoretische Hintergrund wurde in der Vorlesung
„Messunsicherheiten und lineare Regression“ behandelt und kann in den auf der Homepage aufgeführten
Lehrbüchern und Skripten nachgelesen werden. Für diese Vorübung werden Ihnen Daten zur Verfügung
gestellt, die Sie ebenfalls von der Homepage des Grundpraktikums herunterladen können.
Diese Anleitung zeigt Beispiele von Abbildungen, die mit dem Programm QtiPlot erstellt wurden.
Dieses Programm ist kostenlos und für PC, Mac oder LINUX-Rechner auf der Internetseite des HIZ-
Saarland verfügbar. Detaillierte Anleitungen finden Sie in der Hilfefunktion des Programms und in einer
Zusammenstellung „Frequently Asked Questions“ (FAQ), die Sie im Anhang dieser Anleitung und auf
der homepage des Grundpraktikums finden können. Sie dürfen auch ein anderes Programm verwenden,
das die notwendigen Funktionen bietet, sofern Sie es beherrschen.
Dokumentieren Sie detailliert Ihrer Auswertungen in Ihrem Laborbuch oder, falls Sie noch keines haben,
vorläufig auf einem Notizblock. Falls Ihnen kein Drucker zur Verfügung steht, versehen Sie die Grafiken
mit Ihrem Namen, drucken Sie die Abbildungen zunächst im pdf-Format und dann vor dem ersten
Versuch „Messunsicherheiten“ im Labor des Grundpraktikums auf Papier. Übertragen Sie spätestens
dann auch die Notizen zur Auswertung in Ihr Laborbuch.

1 Lernziele
• Bedienung der Software zur Auswertung von Messdaten,
• grafische Darstellung (scatter plot, Histogramm),
• lineare und nichtlineare Regression,
• statistische Analyse von Messdaten,
• Quantifizierung der Messunsicherheit (Vertrauensbereich),
• Lineare Fehlerfortpflanzung.

2 Experimenteller Aufbau (zur Information)

• Feste Aufhängung,
• Feder mit unbekannter Federkonstante D,
• Gewichte M1—M10,
• mm-Skala mit verschiebbarer Markierung,
• Stoppuhr.
• Auswerteprogramm, z.B. QtiPlot
• Hilfe, z.B. „Frequently Asked Questions“ (FAQ) zu

QtiPlot,

3 Messung - Durchführung - Auswertung
Nachdem ein Gewicht Mi an die Feder gehängt wurde und die Ruhelage erreicht hat, wird diese Position
auf der Skala markiert. Anschließend wird die Masse in vertikale Schwingung versetzt. Mit Hilfe der
Stoppuhr wird die Periodendauer der Schwingung gemessen, in dem die Uhr beim Durchlaufen der
Ruheposition gestartet und beim nächsten Passieren in derselben Bewegungsrichtung gestoppt wird. Die
Masse der Gewichtsstücke wird mit einer Waage (Auflösung der Anzeige 0.1 g) gemessen.
Ausnahmsweise führen Sie dieses Experiment nicht selber durch sondern laden für diese Vorübung die
Messdaten von der homepage des Grundpraktikums herunter.

Lesen Sie die Aufgabenstellung vollständig und aufmerksam
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3.1 Übung 1: Statistische Auswertung eines Datensatzes

In der ersten Übung wird der Datensatz grafisch dargestellt und statistisch ausgewertet (Mittelwert,
Standardabweichung, Mittelwert der Standardabweichung). Außerdem wird ein Histogramm der Peri-
odendauern erstellt und mit der Gaußverteilung für die zuvor bestimmten Parameter verglichen.

1) Das Gewicht M4 wurde zehn Mal auf die Waage gelegt und in jedem Fall wurde die Masse 100.2 g
angezeigt.

2) Anschließend wurde das Gewicht an der Feder montiert und die Periodendauer der Schwingung, wie
oben beschrieben, N = 200 Mal gemessen. Die Ergebnisse wurden einer Tabelle (Periodendauer-
M4.dat) gespeichert.

3) Laden Sie die Datei von der homepage des Grundpraktikums herunter.

a) Öffnen Sie das Auswerteprogramm
b) Importieren (>FAQ-F5) Sie den Datensatz „Periodendauer-M4.dat“ in eine Tabelle. Die erste

Zeile der Datei enthält die Spaltenbezeichnungen. Das richtige Dezimaltrennzeichen erkennen Sie
daran, dass die Periodendauern in Spalte 2 Werte von ca. 1 s haben.

c) Erstellen Sie einen scatter plot (>FAQ-F7)
d) Passen Sie die Achsen (Skalen, Beschriftung), Marker (Größe, Farbe) sinnvoll an, so dass alle

wichtigen Details gut erkennbar sind (>FAQ-F10).
e) Führen Sie eine statistische Analyse der Periodendauern durch (>FAQ-F11). Tragen Sie die

Anzahl der Messwerte N, den Mittelwert der Periodendauer {T4} und die Standardabweichung
sT4

in Ihr Laborbuch ein.

f) Berechnen Sie die Standardabweichung des Mittelwertes s{T4} = sT4
/
√

N (Laborbuch).
g) Die Zahlenwerte für die Periodendauer {T4} ± s{T4} werden im Grundpraktikum auf der ersten

signifikanten Dezimalstelle der Unsicherheit gerundet. Tragen Sie das Gesamtergebnis in Ihr
Laborbuch und auf dem scatter plot ein (>FAQ-F13).

h) Drucken Sie das formatierte Diagramm aus und kleben Sie es in das Laborbuch (siehe Hinweis in
der Einleitung).

i) Erstellen Sie ein Histogramm der Daten (>FAQ-F14). Formatieren Sie die Grafik, variieren Sie
beispielsweise auch die Bin Size B (>FAQ-F15).

j) Fügen Sie eine Gaußfunktion

y =
NB

√

2πs2
T

exp

(

− (T − {T})2

2s2
T

)

(1)

mit der Bin Size B und den Parametern N, {T4} und sT4
aus der statistischen Analyse für die

Masse M4 in das Diagramm ein (>FAQ-F16).
k) Drucken Sie das formatierte Diagramm aus und kleben Sie es in das Laborbuch.

Die hier dargestellten Beispiele sind Bildschirmanzeigen in QtiPlot, die beim Ausdruck umskaliert
werden.
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3.2 Übung 2: Fehlerfortpflanzung

Die Periodendauer eines idealen Federpendels beträgt

T = 2π
√

M/D (2)

mit der Federkonstanten D. Aus der Masse M4 und der Periodendauer T4 soll die Federkonstante
berechnet werden. Wegen der Unsicherheiten der beiden Eingangsgrößen ist auch die daraus berech-
nete Federkonstante nicht exakt, der Vertrauensbereich kann aber mit Hilfe der Fehlerfortpflanzung
abgeschätzt werden.

1) Der Mittelwert und die Unsicherheit der Periodendauer wurde in Übung 1 ermittelt.
2) Die Beobachtung desselben Messwertes der Masse bei zehnmaliger Wiederholung legt den Schluss

nahe, dass die statistschen Schwankungen so gering sind, dass sie auf der Skala der Waage
nicht angezeigt werden. Daher wird die Unsicherheit der Masse durch die Auflösung der Anzeige
bestimmt, d.g. u({M}) = 0.1 g.

a) Lösen Sie Gleichung 2 nach D auf und berechnen Sie mit den Mittelwerten {M4} und {T4} die
Federkonstante D in der Einheit [N/m].

b) Notieren Sie in Ihrem Laborbuch die einzelnen Schritte zur Berechnung der linearen Fehlerfort-
pflanzung.

• Bestimmen Sie zuerst formal die partiellen Differentialquotienten ∂D/∂M und ∂D/∂T.
• Setzen Sie in beide Terme die Werte {M4} und {T4} ein.
• Berechnen Sie nun die Unsicherheit uabs(D) = |∂D/∂M|u(M) + |∂D/∂T|u(T).a

c) Notieren Sie im Laborbuch das Gesamtergebnis D ± uabs(D) in der Einheit N/m und gerundet
auf die erste signifikante Dezimalstelle der Unsicherheit.

aBei der Abschätzung des Größtfehlers werden die einzelnen Beiträge der Eingangsgrößen aufsummiert (linearen Fehlerfort-
pflanzung). Unter bestimmten Voraussetzungen wird alternativ die weniger pessimistische Gaußsche Fehlerfortpflanzung
verwendet, bei der die Unsicherheit der abhängigen Größe aus der Wurzel der aufsummierten Quadrate der Einzelbeiträge
berechnet wird.

3.3 Übung 3: Lineare Regression und Bestgerade

Das Experiment aus Übung 1 wurde mit zehn verschiedenen Massen durchgeführt. Ein Blick auf Formel
2 zeigt, dass ein linearer Zusammenhang T2 = A · M mit A = 4π2/D gilt. Bei einer Auftragung von
T2

i gegen die Massen Mi sollten die Datenpunkte auf einer Gerade mit Steigung A liegen, aus der die
Federkonstante berechnet werden soll.

1) Laden Sie den Datensatz mit den zehn Wertepaare ({Mi}, {Ti}) von der homepage des Grund-
praktikums herunter.

a) Öffnen Sie das Auswerteprogramm
b) Importieren Sie den Datensatz „Periodendauer-M1-10.dat“ in eine Tabelle.
c) Erstellen Sie eine neue Spalte und berechnen Sie darin T2 (>FAQ-F6).
d) Erstellen Sie einen scatter plot T2(M).
e) Passen Sie die Achsen (Skalen, Beschriftung), Marker (Größe, Farbe) sinnvoll an.
f) Bestimmen Sie die Bestgerade T2 = A · M (Ursprungsgerade ohne konstanten Term) durch lineare

Regression a (>FAQ-F18)
g) Tragen Sie das Resultat für A mit korrekter Einheit in Ihr Laborbuch. Berechnen Sie aus der

Steigung die Federkonstante D. Berechnen Sie aus der angegebenen Unsicherheit der Steigung
die Unsicherheit der Federkonstanten.

h) Tragen Sie das Ergebnis in der Einheit N/m und richtig gerundet in Ihr Laborbuch ein.
i) Kleben Sie die ausgedruckte Grafik in Ihr Laborbuch.
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aHinweis zum Begriff lineare Regression: Die Terme Bestgerade und linear scheinen dasselbe zu beschreiben. Jedoch
bezieht sich Gerade auf den Zusammenhang zwischen T2 und der unabhängigen Variable M, wohingegen der Begriff linear

bedeutet, dass der Modellparameter A linear in die Berechnung eingehen. Ein Beispiel, auch die Anpassung von Daten mit
einer Funktion f (x) = A · x2 + B · sin (x) mit Vorfaktoren A und B als Fitparameter entspricht einer linearen Regression
obwohl f (x) keine Gerade darstellt.
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QtiPlot - Frequently Asked Questions       (V1 14.12.2021) 

Grundeinstellungen  

• Wir empfehlen, einige Änderungen in den Grundeinstellungen des Programms. Dazu finden Sie auf der 
Internetseite des HIZ (Qtiplot Campuslizenz) neben den Installationsdateien eine Konfigurationsdatei 
(“empfohlene Programmeinstellungen”, download mit rechtem Mausklick) zum Importieren: 
> Edit > Preferences > Load Settings...” (ganz unten), “suggested_qtisettings.ini” auswählen und laden. 

 
Allgemeine Hinweise zum Zahlenformat  

• Je nach Spracheinstellungen zählt entweder der Punkt oder das Komma als Dezimaltrennzeichen. Im Physik 
Grundpraktikum ist auf allen PCs das englischsprachige Zahlenformat eingerichtet, daher muss dort der Punkt 
verwendet werden.  

• Das Zahlenformat 1.23e+04 bedeutet 1.23104 = 1.2310000 = 12300 
 

Noch ein guter Rat – speichern Sie während der Auswertung regelmäßig Ihre Datei um Datenverlust bei einem 
möglichen Absturz des Programms zu vermeiden! 
 
F1: Wie wähle ich eine Spalte, eine Zeile oder die gesamte Tabelle aus? 

• Um eine einzelne Spalte, eine einzelne Zeile oder die gesamte Tabelle auszuwählen, klicken Sie mit der 
linken Maustaste auf den Spaltenkopf (oben), den Zeilenkopf (links) oder das Feld in der linken oberen Ecke. 
Mit gedrückter “Shift”-Taste können Sie wie gewohnt auch mehrere Elemente auswählen. 
 

F2: Wie ändere ich die Spaltenbezeichnungen? 
rechter Mausklick auf den Spaltenkopf > Column Options...> Column Name: _ > Apply 

 
F3: Wie erzeuge ich eine neue Tabelle? 

> File > New > New Table oder (Strg + t) 
 

F4: Wie importiere ich Daten aus dem clipboard? 
 Linker Mausklick in die erste Zelle (z.B. Spalte 1, Zeile 1), rechter Mausklick > Paste  

Hinweis zum Import aus CassyLab: Die Tabelle enthält eine Kopfzeile mit Spaltenbeschriftungen. QtiPlot 
fragt, wie die erste Zeile interpretiert werden soll. Wählen Sie “Column Names” oder “Ignore”. 

 
F5: Wie importiere ich Daten aus einer Datei? 

> File > Import ASCII …  
Die Einstellungen hängen vom Format der Datendatei ab. Achten Sie insbesondere auf die richtige 
Einstellung des Dezimaltrennzeichens und möglicher Kopfzeilen. Das Import-Fenster zeigt eine Vorschau der 
Datentabelle.  
 

F6: Wie füge ich eine neue Spalte ein und berechne die Spaltenwerte? 

• Rechter Mausklick in die Tabelle > Add Column oder Doppelklick rechts neben den letzten Spaltenkopf 
• Spalte auswählen > Set Column Values oder in den Column Options das ∑-Symbol anklicken.  

• den Funktionsausdruck (z.B. col(“2”)^2) eintragen > Apply 
 

F7: Wie erstelle ich einen scatter plot? 
rechter Mausklick auf den [Y]-Spaltenkopf in der Tabelle > Plot > Symbol > Scatter 
(Hinweis: Die Einträge in der Tabelle müssen als „Zahlen“ formatiert sein. Bei Bedarf überprüfen und 
korrigieren: rechter Mausklick auf Spaltenkopf > „Column Options“) 

 
F8: Wie lege ich fest, welche Spalte die x- und die y-Achsen definieren? 

Wählen Sie die Spalte aus, rechter Mausklick > set as ...(X, Y, none...) 
 

F9: Wie entferne ich einen offensichtlichen 1) Ausreißer aus der Grafik?  
Grafik auswählen > Data > Remove Bad Data Points > (…Continue) > Doppelklick auf den Punkt 

Das Entfernen eines Datenpunktes ist eine Manipulation des Ergebnisses und darf nicht ohne 
Begründung erfolgen. Die Aussage „Der Punkt liegt nicht an der Stelle, wo ich ihn gerne hätte“ stellt keine 
ausreichende Begründung dar. 
 

F10: Wie ändere ich Elemente (Achsenskalierung, Beschriftungen…) in einer Grafik? 
rechter Mausklick auf das grafische Element > Properties 
 

F11: Wie ermittle ich Mittelwert und Standardabweichung einer Datenreihe? 
rechter Mausklick auf den Spaltenkopf in der Tabelle > Statistics on Columns 
 
 



F12: Wie füge ich eine Linie in die Grafik ein oder lösche eine Kurve? 

• Erstellen Sie eine neue Tabelle (siehe F3)  
• tragen Sie die x- und y-Werte für den Anfangs- und Endpunkt der gewünschten Linie ein 
• Wählen Sie das Grafikfenster und dann im Menü > Graph > Add/remove curves  

• Wählen Sie nun in dem Dialogfenster unter “Available Data” die Tabelle mit den Linienkoordinaten aus und 
klicken Sie auf den oberen Pfeil. Dadurch werden die Daten in das Feld graph contents übertragen. > Ok  

• Falls die Endpunkte mit Markern versehen sind, klicken Sie mit der rechten Maustaste auf die Linie > 
properties, wählen Sie die Tabelle und stellen Sie plot type auf “line”. 

• In dem Dialogfenster Add/remove curves können Sie auch eine Kurve aus dem Diagramm entfernen 
 

F13: Wie füge ich ein Textfeld in eine Grafik ein? 
> Graph > Add Text > linker Mausklick in die Grafik öffnet den Texteditor (Das Textfeld kann mehrzeilig sein) 
 

F14: Wie erstelle ich aus den Daten einer Tabellenspalte ein Histogramm? 
rechter Mausklick auf Spaltenkopf > Plot > Statistical Graphs > Histogram 
 

F15: Wie passe ich die Balkenaufteilung („bin size“) des Histogramms an? 
rechter Mausklick auf Balken > Properties, Dateneintrag auswählen > Histogram Data >  
uncheck „Automatic Binning“, danach “Bin Size”, “Begin” und “End” der Größenklassen sinnvoll einstellen. 
 

F16: Wie füge ich einen Funktionsgraphen, z.B. eine Gaußfunktion in die Grafik ein? 

• Grafikfenster auswählen, > Menü Graph > Add function.  

• Im Feld “f(x)=” den Funktionsausdruck (z.B.  (N*B/sqrt(2*pi*s^2))*exp(-(x-x0)^2/(2*s^2)) eintragen.  
• Wenn Sie für Parameter keine Zahlenwerte sondern Buchstaben verwenden, öffnet sich ein Fenster, in dem 

jedem Parameter ein Wert zugeordnet und später einfach verändert werden kann. Das ist nützlich, wenn der 
Parameter im Funktionsausdruck mehrfach auftaucht. 

• Den Start- und Endwert von x und die Anzahl der Punkte festlegen, für die f(x) berechnet werden soll > Apply 
 

F17: Wie kann ich eine Funktion nachträglich verändern? 

• Rechter Mausklick in die Grafik > Properties 

• Im linken Fenster die Funktion auswählen > Function  
 

F18: Wie ermittle ich die beste Ursprungsgerade durch Datenpunkte in einer Grafik? 

• rechter Mausklick in die Grafik > Analyze > Fitting > Fit slope 

• Falls die Grafik mehrere Datensätze enthält, öffnet sich ein Fenster zur Auswahl. 
• Das Ergebnis der Regression finden Sie im Fenster “Results log”, das Sie ggf. unter >View aktivieren müssen 
 

 
F19: Die Fitkurve beginnt nicht im Achsenursprung. Wie kann ich das anpassen? 

• rechter Mausklick in die Grafik > Properties 
• in der Elementliste die Fitgerade auswählen und unter der Formel “From x=... To x=...” anpassen > Apply 

 
 

F22: Wenn ich die Fenstergröße ändere, dann wird die Graphik nicht mitskaliert. Wie kann ich das ändern? 

• Edit > Preferences > 2D Graphics > Options >  

• tickmark entfernen bei „do not rescale layer upon change of window size“  
Siehe auch Grundeinstellungen (oben) 
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